В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
314159026
314159026
09.06.2022 23:04 •  Информатика

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям: автор, название, год издания. провести сортировку и вывести список книг, изданных после 2003 года. 2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.

Показать ответ
Ответ:
larkina2000
larkina2000
12.06.2020 11:46

Сделано для трёх книг, потом поменяешь в двух местах

PROGRAM prim2;
uses crt;
Type
book=record
avtor: string[20];
name:string[25];
year:integer;
end;

Var
f,i: integer;
b:array[1..3] of book;
BEGIN
clrscr;
f:=0;
{формирование записей}
for i:=1 to 3 do
Begin
write('Введите название книги: ');
readln(b[i].name);
write('Введите фамилию автора: ');
readln(b[i].avtor);
write('Введите год издания: ');
readln(b[i].year);
end;
writeln;
Writeln('Сведения о книгах (автор,название,год издания) год издания которых позже 1990');
for i:=1 to 3 do
Begin
if b[i].year>2003 then {проверка условия задачи}
Begin
f:=f+1;
Writeln(f:6,' ', b[i].avtor,' ', b[i].name,' ', b[i].year);
end;
end;
writeln('Итог: ',f);
readln;
END.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота