В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
alexfuerte07
alexfuerte07
08.08.2021 08:41 •  Информатика

1) составить программу(паскаль) вывода на экран трёхзначных нечётных чисел которые оканчиваются на 3 2) составить программу последов. чисел целых чисел определить наименьшее четное отрицательное число. о признак окончания ввода ( min = 30.000 ) 3) последов. целых чисел найти среднее арифметических чётных чисел. о- признак окончания ввода ( integer, k 10000 ) s/n

Показать ответ
Ответ:
MrAziimov1
MrAziimov1
05.10.2020 20:35
//PascalABC.Net 3.2
//1
begin
for var i:=100 to 999 do if i mod 10 = 3 then print (i);
end.

//2
begin
var min:=30000; var n:=0;
repeat
n:=readinteger('Введите число: ');
if (n.iseven) and (n<0) and (n<min) then min:=n;
until n=0;
write ('Min: ', min);
end.

//3
begin
var sum:=0; var n:=0; var a:=0;
repeat
a:=readinteger('Введите число: ');
if a.iseven then
begin
sum+=a;
inc (n);
end;
until a=0;
write ('Average: ',sum/(n-1));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота