В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Dengires
Dengires
18.01.2021 02:40 •  Информатика

1. Составить программу вывода на экран квадратов всех целых чисел от a до b. Пример вывода результатов:
2*2=4
3*3=9
4*4=16 и т.д.
2. Для проверки физического развития учеников измеряют вес школьников. Составьте программу, запрашивающую количество учеников в классе, а затем вес каждого школьника. Программа должна вычислить средний вес среди обучающихся осмотр.

Показать ответ
Ответ:
Dozie
Dozie
19.01.2023 13:21
#include <iostream>
using namespace std;
int main() {
        int mat[3][3];
        int k;
        int size=0;
        int * arr=0;
        for(int i=0;i<3;i++){
                for(int j=0;j<3;j++){
                       cin>>mat[i][j];
                          if (mat[i][j]>0){
                             arr=(int*)realloc(arr,sizeof(int)*(++size));
                             arr[size-1]=mat[i][j];
                                             }
                                           }
                                    }
                  for(int i=0;i<size;i++){
                  cout<<arr[i];
                  }
               delete arr;
               cin.get();
               cin.get();
              return 0;
}
0,0(0 оценок)
Ответ:
Саша030612
Саша030612
03.03.2023 16:24

Объяснение:

//PascalABC.NET версия 3.2, сборка 1389

//Если программа не запускается, то обновите версию

uses System.Linq;

begin

   writeln('III');

   var a := ReadArrInteger('Документы', ReadInteger('n=')).ToList;

   writeln;

   

   while a.Any() do

   begin

       write(a[0], ' ');

       a.RemoveAt(0);

       if not a.Any then break;

       

       write(a.Last, ' ');

       a.RemoveAt(a.Count - 1);

       if not a.Any then break;

       

       var n := 0;

       if a.Count > 1 then n := a.Count div 2 - 1;

       write(a[n], ' ');

       a.RemoveAt(n);

   end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота