В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
serpgo1
serpgo1
26.01.2020 18:42 •  Информатика

1.Составьте программу, которая вводит сумму и произведение натуральных чисел от 2 до 8
2.Составьте программу, которая вводит в порядке возрастания числа кратные трём в диапазоне от 3 до 20

Показать ответ
Ответ:
Lisaezhik
Lisaezhik
11.09.2020 20:56

PASCAL если нет сам виноват

без массивов, это принцип)))

1)

program pas;

var

p, s, i: longint;

begin

p:=1;

s:=0;

for i:=2 to 8 do begin

  p:=p*i;

  s:=s+i;

  end;

write('сумма: ', s, ' произведение: ', p);

end.

2)

program pas;

var

ch, i: longint;

begin

for i:=3 to 20 do begin

  if i mod 3=0 then begin

     ch:=i;

     write(ch, ' ');

  end;

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота