В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
51179
51179
30.05.2023 15:54 •  Информатика

1.составьте программу которая заполняет массив a[1..30] случайными целыми числами в диапазоне от -15 до 30 и вычисляет произведение положительных элементов массива. 2. составьте программу которая заполняет массив a[1..40] случайными целыми числами в диапазоне от -20 до 10 и находит количество элементов массива кратным 3 3. составьте программу которая заполняет массив a[1..40] случайными целыми числами в диапазоне от -30 до 30 и находит среднее арифметическое отрицательных элементов массива

Показать ответ
Ответ:
ника2144
ника2144
07.10.2020 08:09
//Pascal

//1)
var
  A: array [1..30] of integer;
  i: byte; mult: double;
begin
mult := 1;
randomize;
writeln('Сгенерированный массив.');
for i := 1 to 30 do
begin
  A[i] := random(46)-15;
  if A[i] > 0 then mult := mult * A[i];
  write(A[i], ' ');
end;
writeln;
writeln('Произведение положительных элементов = ', mult);
end.
//

//2)
var
  A: array [1..40] of integer;
  i: byte; count: byte;
begin
count := 0;
randomize;
writeln('Сгенерированный массив.');
for i := 1 to 40 do
begin
  A[i] := random(31)-20;
  if A[i] mod 3 = 0 then count := count + 1;
  write(A[i], ' ');
end;
writeln;
writeln('Количество элементов кратных трем = ', count);
end.
//

//3)
var
  A: array [1..40] of integer;
  i: byte; count: byte; sum: integer;
begin
count := 0; sum := 0;
randomize;
writeln('Сгенерированный массив.');
for i := 1 to 40 do
begin
  A[i] := random(61)-30;
  if A[i] < 0 then
  begin
    count := count + 1;
    sum := sum + A[i];
  end;
  write(A[i], ' ');
end;
writeln;
writeln('Среднее арифметическое отрицательных эл. =',(sum/count):4:4);
end.
//
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота