В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Ыыыап
Ыыыап
24.03.2022 10:25 •  Информатика

1. составьте программу в pascal abc. даны три числа. найти сумму двух наибольших из них. 2. составьте программу в pascal abc. для данного вещественного x найти значение следующей функции f, принимающей вещественные значения: f(x)=(2-х)/x2,если x> 0, иначе f(x)=6-х3 3. составьте программу в pascal abc. даны два числа. найти их сумму, разность и произведение.

Показать ответ
Ответ:
krll333
krll333
06.10.2020 11:53
1 задача.
var a, b, c: integer;
begin
  write('Введите через пробел три числа: ');
  readln(a, b, c);
  if (a > b) then
    if (b > c) then
      write('Сумма двух наибольших чисел: ', a + b)
    else
      write('Сумма двух наибольших чисел: ', a + c)
  else
    if (c > a) then 
      write('Сумма двух наибольших чисел: ', c + b)
    else
      write('Сумма двух наибольших чисел: ', b + a)
end.

2 задача.
var x, f: real;
begin
  write('Введите значение x: ');
  readln(x);
  if (x > 0) then
    f := (2 - x) / (x * x)
  else
    f := 6 - (x * x * x);
  writeln('Значение функции при данном x: ', f)
end.

3 задача.
var a, b: integer;
  write('Введите через пробел два числа: ');
  readln(a, b);
  writeln('Сумма чисел: ', a + b);
  writeln('Разность чисел: ', a - b);
  writeln('Произведение чисел: ', a * b)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота