В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

1. составьте программу вычисления суммы чисел в диапазоне от 15 до 65.15+16+17+ +652 а) составьте программу вычисления суммы при заданном k.б)составьте программу вычисления произведения при заданном k.ps: фото к 2-му ​

Показать ответ
Ответ:
nastyaorinozl1jy
nastyaorinozl1jy
07.04.2023 21:23

procedure p(x:integer; var st:string);

type

       name = array[0..9] of String[50];

     const

       s1 : name = (' ноль ',' один ',' два ',' три ',' четыре ',' пять ',' шесть ',' семь ',' восемь ',' девять ');

       s2: name = (' ',' десять ',' двадцать ',' тридцать ',' сорок ',' пятьдесят ',' шестьдесят ',' семьдесят ',' восемьдесят ',' девяносто ');

       s3: name = (' ',' сто ',' двести ',' триста ',' четыреста ',' пятьсот ',' шестьсот ',' семьсот ',' восемьсот ',' девятьсот ');

       s4 : name = (' ',' одиннадцать ',' двенадцать ',' тринадцать ',' четырнадцать ',' пятнадцать ',' шестнадцать ',' семнадцать ',' восемнадцать ',' девятнадцать ');

     var

       s,d,e : Integer;

begin

   s:= x div 100; x:=x mod 100;

   st:=s3[s];

   d:= x div 10; e:=x mod 10;

   if (d=1) and (e<>0) then st:=st+s4[e]

                        else st:=st+s2[d]+s1[e];

end;

var x:integer; st:string;

Begin

    Write('Введите число [0..100] :');

    Readln(x);

    p(x,st);

    writeln(st);

End.

Пример:

Введите число [0..100] : 12

дведнацать

Объяснение:

0,0(0 оценок)
Ответ:
coroleovacarina2013
coroleovacarina2013
09.07.2021 12:38

блачный программный продукт, который позволяет вести неограниченное количество проектов. Например таких масштабных как строительство стадиона, проведение саммита и т.д.

С программным продуктом работают руководители всех уровней, они ставят задачи в рамках проектов и отчитываются об исполнении задач. К успешному исполнению задач и успешной реализации проекта привязаны ключевые показатели эффективности всех участников. Информационная система позволяет руководителю смотреть на проект «с высоты птичьего полета»; любой исполнитель понимает, что от результата его труда зависит общий результат всего проекта.

Программный продукт удобен для работы на мобильных устройствах из любого места и времени.

Суть бренда:

Информационная система предназначена для оперативного и эффективного управления проектами.

Главное отличие от конкурентов:

- Интуитивно понятный интерфейс;

- Проста в освоении;

- Наличие электронного документооборота;

- Одинаково удобна и функциональна как для топ-менеджеров, так и для исполнителей;

- Отечественная разработка, учитывающая особенности управления проектами в России;

- Аналитика исполнения бюджетов, прогноз рисков.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота