В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
GastDaniil
GastDaniil
12.12.2022 19:18 •  Информатика

1. Составьте программу, задающую одномерный массив целых чисел из 6 элементов, вводимых с клавиатуры, и оформите вывод элементов на экран в строчку.
текст программы
var m: array [1..6] of integer;
i: integer;
begin
writeln('ввод элементов');
for i:=1 to 6 do readln(m[i]);
for i:=1 to 6 do write(m[i],' ');
end.

Показать ответ
Ответ:
mahomaev
mahomaev
15.12.2020 23:17
1 задание) ответ: 1323141;
Двигаемся в обратном порядке 2324142 (идём с конца) ей противоположные 1323141
2 задание) ответ: 2949;
мы должны получить 11 и 13 причем минимально . можем только так 9+2 и 9+4 . значит 2949
3 задание)   ответ: 3;
чтобы добраться до 21 нам нужно выполнить 1 команду 6 раз и 3 раза вторую , нас спрашивают про вторую пишем ответ 3
4 задание) ответ: 1;
нам нужно число которое делится на 5 то есть 4 отпадает , и также нам нужно чтобы модуль разности был не более 2 и во втором и в третьем модуль разности больше 2 , остается 1.
5 задание)  ответ: 1112221;
Я всегда начинаю с обратного 
57-56-28-14-7-6-5-4  собираем с конца 1112221 
0,0(0 оценок)
Ответ:
500о
500о
31.03.2021 03:46
Таких систем исчисления всего две.  Основание а = 9 и основание а =367, но в системе с основанием 367 проблематично записывать числа (символов не хватит).
Если число 3306(10) в системе исчисления с основанием а заканчивается цифрой 3, то тогда
число 3303 делится на основание системы а.
Отсюда алгоритм поиска.  Находим все делители числа 3303.
3303 = 3*1101 = 3*3*367.  Число 367 - простое. Поэтому основаниями системы исчисления 
могут быть только 3, 9, 367.  Основание =3 не подходит, так как по условию число должно заканчиваться на 3  -> основание больше 3.  Остаются 9, 367.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота