В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
killir99
killir99
16.12.2020 08:55 •  Информатика

1.Составьте программу закрашивания буквы "Т", размерами четыре клетки по вертикали и три по горизонтали. Начальное положение Робота - где-то в центре поля.

Показать ответ
Ответ:
Tapty
Tapty
25.02.2023 18:50

1.

var

  a: integer;

 

begin

  readln(a);

  if ((a mod 10) mod 2 = 0) and ((a mod 100) mod 2 = 0) then writeln('да')

  else writeln('нет');

end.

2.

var

  a, max: integer;

 

begin

  readln(a);

  max : = -1;

  while a < > 0 do

  begin

    if ((a mod 10) mod 2 = 0) and ((a mod 10) mod 2 > max) then max : = (a mod 10) mod 2;

    a : = a div 10;

  end;

  if max < > -1 then writeln(max)

  else writeln('');

end.

3.

var

  mas: array[0..19] of integer;

  sum, i: integer;

begin

  randomize;

  sum : = 0;

  for i : = 0 to 19 do  

  begin

    mas[i] : = -45 + random(1 + 45 + 55);

    if (mas[i] mod 2 = 0) and (mas[i] > 0) then sum += mas[i];

  end;

  writeln(sum);

end.

0,0(0 оценок)
Ответ:
Kejiro
Kejiro
07.07.2020 01:13

Арифметическое выражение – это запись математической формулы с использованием констант, переменных, функций, знаков арифметических операций и круглых скобок.

Знаки арифметических операций

+ (плюс) сложение

-  (минус) вычитание

* (звёздочка) умножение

/ (следж) деление

** (две звездочки) возведение в степень.

Константы, переменные, указатели функций, а также выражения в круглых скобках называются операндами. Арифметическое выражение может присутствовать в правой части оператора присваивания, в списке фактических параметров при обращении к подпрограмме. Арифметические выражения используются при записи отношений.

ПРИМЕР: Записать на языке Фортран выражение

.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота