1. Составьте программу закрашивания периметра квадрата 3×3, считая, что Робот
находится где-то в центре поля.
2. Необходимо перевести Робота из начального положения (◊) в точку A за минимальное
число шагов любым из возможных Необходимо перевести Робота по лабиринту из начального положения (◊) в точку A.
Вот, нашел на одном из сайтов: #include <iostream>
#include <conio.h>
#include <cstdlib>
#include <ctime>
using namespace std;
int main (){
srand(time(0));
int n, one, two, co=0, ol, k=0, var, sum1=0, sum2=0;
bool kto=true;
cout << "Privet davaii sigraem v kosti.\nPobedit tot u kogo suma 3 broskov budet bolshe\n\n";
while (k<3)
{
cout << "\n1 - Brositj kubik\n2 - Vijti\nViberi variant: ";
cin >> var;
if (var==1)
{
for (int j=0; j<=1; j++)
{
one=1+(rand()%6);
two=1+(rand()%6);
cout << "\n";
if (kto) cout << "\tTvoi kubiki\n";
if (!kto) cout << "\tMoi kubiki\n";
cout << "\n";
for (int i=1; i<=5; i++)
{
if (i==1) n=1;
else if (i==2 && one==1) n=2;
else if (i==2 && one==3 || i==2 && one==2) n=3;
else if (i==2 && one==4 || i==2 && one==5 || i==2 && one==6) n=4;
else if (i==3 && one==3 || i==3 && one==1 || i==3 && one==5) n=5;
else if (i==3 && one==2 || i==3 && one==4) n=2;
else if (i==3 && one==6) n=4;
else if (i==4 && one==1) n=2;
else if (i==4 && one==3 || i==4 && one==2) n=6;
else if (i==4 && one==4 || i==4 && one==5 || i==4 && one==6) n=4;
else if (i==5) n=7;
switch (n){
case 1:
cout << (char)201 << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)187;
break;
case 2:
cout << (char)186 << " " << (char)186;
break;
case 3:
cout << (char)186 << " o " << (char)186;
break;
case 4:
cout << (char)186 << " o o " << (char)186;
break;
case 5:
cout << (char)186 << " o " << (char)186;
break;
case 6:
cout << (char)186 << " o " << (char)186;
break;
case 7:
cout << (char)200 << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)188;
break;
}
if (co%2==0) {
cout << "\t";
i--;
ol=one;
one=two;}
else {
cout << endl;
one=ol; }
co++;
}
if (kto){
sum1=sum1+one+two;
kto=false;
continue;
}
if(!kto){
sum2=sum2+one+two;
kto=true;
}
}
}
else if (var==2) return 0;
else {
cout << "\n!!! Viberi variant 1 ili 2 !!!\n";
continue;}
k++;
}
cout << "\nTvoj rezultat = " << sum1 << endl << "Moj rezultat = " << sum2 << endl;
if (sum1>sum2)
cout << "\n\tTi pobedil ;)";
else cout << "\n\tTi proigral :(";
getch ();
}
Для того чтобы работать с текстами на персональном компьютере или ноутбуке обычно используют специальные программные средства, которые принято называть текстовыми редакторами. Стоит отметить, что на сегодняшний день существует довольно большое разнообразие подобных программ, которые различаются своими возможностями и функциями, но наиболее популярным (по числу использования пользователями) остается MS Word 2010.
Вообще, основным назначением текстовых редакторов является создание текстовых файлов, редактирование уже готовых (или недоделанных) текстов с возможностью их на экране, изменять их формат, а также распечатывать на принтере. Кстати, следует уточнить, что Блокнот и другие аналогичные редакторы предназначены только для обработки несложных текстовых файлов, но никак не для работы с большим текстом.
Самым большим по своим возможностями до сих пор считается MS Word — текстовый редактор от компании Microsoft. В нем так же, как и во многих его аналогах можно:
форматировать символы, абзацы;
оформлять страницы;
"строить" указатели и оглавления;
включать в тесты графические объекты: фотографии, диаграммы, рисунки;
создавать таблицы, проверять правописание и т. д.
В современном мире существует уже много версий MS Word, наиболее популярными среди них считаются версии 2003, 2007, 2010 и 2013 года выпуска. Современный текстовый процессор Microsoft Word предназначен для создания, печати и модификации текстовых документов. Он предусматривает выполнение многих операций, как над текстовой, так и над графической или табличной информацией. Благодаря MS Word стало возможно быстро, а также с высоким качеством подготовить любой документ, причем от сложного до дает возможность осуществлять все традиционные операции над текстом (без исключений), которые предусмотрены в компьютерной современной технологии. С его можно:
модифицировать набор неформатированной цифровой и алфавитной информации;
форматировать символы, применяя множество шрифтов разных размеров и начертаний;
форматировать страницы (сюда также входят сноски, колонтитулы);
форматировать документ в целом (составлять оглавление, причем автоматическое, а также разные указатели);
подбирать синонимы, проверять правописание, использовать автоматический перенос слов.
В этой программе реализованы возможности новых технологий связывания, внедрения объектов, благодаря которым можно в документ включать таблицы, текстовые фрагменты и иллюстрации.
Это одна из первых общедоступных программ, с которой можно выполнять операции верстки, которые порой необходимы издательским профессиональным системам, а также с ее можно подготавливать полноценные оригинал-макеты для их последующего тиражирования в типографии.
Данная программа является уникальной коллекцией технологических оригинальных решений, благодаря которым нудная и кропотливая работа по отделке и редактированию текста превращается в увлекательное, а порой и успокаивающее занятие. В число таких решений входит система готовых стилей оформления и решений, изящные приемы по модификации и созданию таблиц, функции автозамены и автотекста, а также копирование формата, макроязык, пользовательские панели инструментов и многое другое.
Многие привыкли к другим же нравится оригинальный интерфейс версий 2007 или 2010 года выпуска. В основном же это дело привычки. Самое главное, что в современном мире это самый удобный, интуитивно-понятный и полезный инструмент для работы с текстовыми файлами