В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Dianissimolps
Dianissimolps
12.10.2022 21:02 •  Информатика

1. В массиве хранятся данные о ежедневной температуре в течение августа (случайные числа от 15 до 25). Составьте программу для нахождения среднемесечной температуры. 2. Массив содержит информацию об отметках по информатике 20 учащихся класса. Отметки вводятся с клавиатуры. Составьте программу, которая вычисляет средний по предмету и количество учащихся с отметками выше среднего

Показать ответ
Ответ:
SophiaSaliuk
SophiaSaliuk
20.10.2020 17:01

program xxx;

var i, m, p, n : integer;

t : array[1..31] of real;

begin

writeln('введите температуру ')

for i:=1 to 31 do

readln(t[i]);

m:=0; p:=0; n:=0;

for i:=1 to 31 do

begin

if t[i]<0 then m:=m+1;

if t[i]>0 then p:=p+1;

if t[i]=0 then n:=n+1

end;

writeln('Дней с отрицательной температурой было - ', m);

writeln('Дней с положительной температурой было - ', р);

writeln('Дней с нулевой температурой было - ', n);

readln

end.

Объяснение:

Прописка

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота