В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Ponomorev
Ponomorev
21.05.2022 17:39 •  Информатика

1) В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 1, 2, 5, 8, 9, 3, 4, 0, 7, 6 соответственно, т. е. A[0] = 1, A[1] = 2 и т. д. Определите значение переменной j после выполнения следующего фрагмента программы (записанного ниже на пяти языках программирования).
j := 5;
while A[j] A[i] then
begin
c := c + 1;
t := A[i];
A[i] = A[i − 1];
A[i − 1] = t;
end;
5) Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 3, 5, 4, 2, 7, 4, 3, 1, 2, 6 (т.е. A[0] = 3, A[1] = 5, …, A[9] = 6). Определите значение переменной s после выполнения фрагмента.

N := 9;
s := 0;
for i:=0 to N do begin
if A[i] < A[N] then begin
A[i] := A[i] + 1;
A[N] := A[N] − 1;
s := s + 1;
end;
end;

Показать ответ
Ответ:

const

 n=10; 

var

  a:array[1..n] of integer;

  i,x,k,j,s:integer; 

begin

randomize:

for i:=1 to n do a[i]:=random(255);     {формируем случайный массив}

for i:=1 to n do write(a[i],' ');             {выводим этот массив его на экран}

writeln('x='); read(x);                         {вводим x, в программе}

for i:=1 to n do If x=a[i]                     {если х=a[i] тогда}

then for j:=i to n do                          {начинаем новый цикл с i до n}

        S:=S+a[j];                                 {вычисляем сумму}  

writeln(S);                    

end;

0,0(0 оценок)
Ответ:
Юля5454554
Юля5454554
05.07.2022 06:54

Чтобы восстановить оригинальное программное обеспечение, необходимо скачать последнюю для PS3. Получить ее можно несколькими Самый вариант – установить обновление с игрового диска. Если игра более-менее новая, при запуске она по загрузить апдейт системы. Соглашайтесь и ждите окончания процесса. После этого можно сделать полное восстановление системы. Об этом мы расскажем в конце.

Если диска нет, посетите официальный сайт находится в разделе с обновлениями. Скачайте необходимые файлы, а потом поместите их на обычную флешку. При включении консоли появится сообщение, в котором система обратится к вам с предложением заменить нынешнюю версию ПО на новую.

Последняя версия для PS3 откроет доступ к сервису PSN, через который вы сможете покупать игры и запускать их в онлайн-режиме.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота