В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
DimaKravshenco
DimaKravshenco
23.09.2020 11:26 •  Информатика

1. Введите с клавиатуры в массив десять вещественных значений. Выведите их в одну строку через пробел. Отсортировать по убыванию и вывести полученный массив на экран. 2. Составьте программу упорядочения по убыванию элементов каждого столбца двумерного массива C[1.5, 1..6]. Массив заполнен случайными целыми числами от -20 до 20
решить эти две задачи по PascalABC
с алгоритма и программ с использованием методов внутренней сортировки.

Показать ответ
Ответ:
raminqedimov543
raminqedimov543
01.03.2023 17:21

ответ: 1 - C, 2 - B, 3 - B, 4 - B, 5 - B, 6 - C, 7 - B, 8 - B, 9 - C, 10 - D, 11 - A, 12 - B, 13 - B, 14 - B, 15 - D, 16 - C, 17 - B, 18 - D, 19 - C, 20 - B, 21 - D, 22 - B, 23 - B, 24 - C

Объяснение:

1. Предмет информатики — это накопления, хранения, обработки, передачи информации;

2. Тройками из нулей и единиц можно закодировать 8 различных символов.

3. Капитан спрашивает матроса: «Работает ли маяк?» Матрос отвечает: «То загорается, то погаснет!» Чем является маяк в этой ситуации? -  источником информации.

4. В каком веке появились первые устройства выполнять арифметические действия? -  В XVII в.

5. Механическое устройство, позволяющее складывать числа, изобрел Б. Паскаль.

6. Для какой системы счисления были при первые семикосточковые счеты? - для десятичной;

7. Какое устройство в России получило название «железный Феликс»? - механический арифмометр;

8. В какие годы XX столетия появилась первая электронно-счетная машина? - в 40-е;

9. В каком поколении машин ввод данных можно осуществлять с речи? -  4-м;

10. Архитектура компьютера — это описание устройства и принципов работы компьютера, достаточное для понимания пользователя.

11. Что такое микропроцессор? - Интегральная микросхема, которая выполняет поступающие на ее вход команды (например, вычисление) и управляет работой машины;

12. Подключение отдельных периферийных устройств компьютера к магистрали на физическом уровне возможно с контроллера;

13. Внешняя память необходима для  для долговременного хранения информации после выключения компьютера;

14. Для построения с компьютера сложных чертежей в системах автоматизированного проектирования используют графический планшет (дигитайзер);

15. К устройствам накопления информации относится ВЗУ.

16. Что из перечисленного не относится к программным средствам? - процессор;

17. Файлом называется поименованная область на диске или другом машинном носителе;

18. В каком файле может храниться рисунок? -  CREML.BMP.

19. Могут ли два каталога 2-го уровня иметь одинаковые имена? - да, если они принадлежат разным каталогам 1-го уровня;

20. Необходимым компонентом операционной системы является командный процессор;

21. Что такое система счисления? - это знаковая система, в которой числа записываются по определенным правилам, с знаков некоторого алфавита, называемых цифрами.

22. Какие системы счисления не используются специалистами для общения с ЭВМ? - троичная;

23. Что называется основанием системы счисления?» - отношение значений единиц соседних разрядов;

24. Все системы счисления делятся на две группы: позиционные и непозиционные;

0,0(0 оценок)
Ответ:
лиана250
лиана250
18.03.2021 23:42
Общее решение, позволяющее удалять из строк любой "мусор"

// PascalABC.Net 3.0, сборка 1066
procedure CheckString(var s:string; var n:integer);
var
  i:integer;
begin
  i:=Length(s);
  while i>0 do begin
    if not(s[i] in ['a'..'z']) then Delete(s,i,1);
    Dec(i)
  end;
  n:=Length(s)
end;

var
  s1,s2:string;
  i,p,n1,n2:integer;
begin
  Write('Введите первую строку: '); Readln(s1);
  CheckString(s1,n1);
  if n1=0 then Writeln('Введенная строка не содержит допустимых символов')
  else begin
    Write('Введите вторую строку: '); Readln(s2);
    CheckString(s2,n2);
    if n2=0 then Writeln('Введенная строка не содержит допустимых символов')
    else
      { теперь обе строки содержат только маленькие латинские буквы }
      if n1=n2 then begin
        for i:=1 to n1 do begin
          p:=Pos(s1[i],s2);
          if p=0 then Break
          else Delete(s2,p,1)
          end;
        if Length(s2)=0 then Writeln('Решение имеется')
        else Writeln('Решения нет')
        end
      else
        Writeln('Решения нет');
    end
end.

Тестовое решение:
Введите первую строку: this is my own deal!
Введите вторую строку: Тест: *is  now=l2ead  my   sthi?
Решение имеется

Также имеется современное решение, которому пока что в школах не учат:
// PascalABC.Net 3.0, сборка 1066
begin
  var s1:=ReadString('Введите первую строку: ').Where(x->x in ['a'..'z']);
  if s1.Count=0 then
    Writeln('Введенная строка не содержит допустимых символов')
  else begin
    var s2:=ReadString('Введите вторую строку: ').Where(x->x in ['a'..'z']);
    if s2.Count=0 then
      Writeln('Введенная строка не содержит допустимых символов')
    else
      if s1.Except(s2).Count>0 then Writeln('Решения нет')
      else Writeln('Решение имеется')
    end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота