1. Выписать те последовательности символов, которые могут быть идентификаторами в Паскале:
а) XY б) число в) max г) 5ab д) c5
2. Написать программу на Паскале:
Даны два числа. Большее из них уменьшить на 15, а меньшее возвести в куб. Вывести результат
3. Записать выражение в традиционной математической форме:
у= SQR(5*х) – SQRT(x / 2*x + 1)
Записать выражение на Паскале:
y=(2.5-1\2x^3)\sinП\4 +0.9)
#include <iostream>
using namespace std;
int main(){ cout << "Vvedute kol-vo ocenok" << endl;
int n,i,a,Four,Five; n = i = a = Four = Five = 0;
cin >> n;
for (i = 1; i <= n; i++) { cin >> a; if (a == 4){ Four++;} else if (a == 5) { Five++; } } if (Four > Five){ cout << "Four" << endl;} else if (Five > Four) { cout << "Five" << endl; } else { cout << "Equal"<< endl; } cout << "Kol-vo 4: " << Four << " Kol-vo 5: " << Five << endl; return 0;}
FOR i = 1 TO 100
percents = FIX(x * p / 100) ' здесь у нас есть переменная percents, которой присваиваются округленные функцией fix проценты (насколько я знаю, в паскале аналогичная функция называется Round)
x = x + percents 'тут всё понятно - переменной X присваивается она сама и годовые проценты по вкладу
IF x >= y THEN 'проверяем, не равен или не превысил ли наш вклад ожидаемую сумму
PRINT i 'в цикле For можно не заморачиваться с отслеживанием лет, переменная i сама подсчитает количество итераций-лет
END 'завершаем программу
END IF
NEXT i ' конец цикла
Можно ещё чисто для себя добавить в условие вывод переменной X, чтобы было нагляднее.