В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
gushagusha
gushagusha
27.08.2020 17:32 •  Информатика

1)выяснить, есть ли в массиве строки, в которых буква а расположена справа от

буквы д (известно, что буква д в каждой строке единственная).

2) дан динамический массив целых чисел {ai} (i=1, 2, ), целое число k

(k > 0). осуществить циклический сдвиг значений компонентов массива в

право на 1 компонент. для обращение к элементам массива использовать

указатель

3) имеется множество, содержащее натуральные числа из диапазона [-

99..99]. сформировать два множества, первое из которых содержит все числа из

данного множества, которые делятся на 3 и 5, а второе — все составные.

4) дано слово. поменять местами его вторую и предпоследнюю буквы.

5) дано множество m, содержащее цветов {крокус: март-апрель,

нарцисс: апрель-май, лилия: июнь-июль, тюльпаны: апрель-май, гладиолус: августсентябрь} . написать программу, которая позволит пользователю вводит название

цветка и видеть период цветения.

6) дан массив целых чисел a. найти суммы положительных и отрицательных

элементов массива, используя функцию определения суммы.

p.s. программы должны быть на delphi!

Показать ответ
Ответ:
popirina2001
popirina2001
28.11.2022 18:06

Netflix - американский стриминговый сервис, специализирующийся на показе мультфильмов, фильмов, и сериалов на основе потокового мультимедия. Netflix стремится изменить наш подход к просмотру киноиндустрии в целом.

С 2013 года Netflix производит собственные фильмы, сериалы и телепрограммы. В 2016 году компания выпустила 126 оригинальных сериалов и фильмов — больше, чем любой другой сетевой или кабельный канал. По состоянию на январь 2019 года у компании насчитывалось 139 миллионов подписчиков по всему миру, в том числе 58,49 млн в США.

P.s Если не трудно, поставь пять звезд, нажми " " и сделай лучшим ответом, я хочу получить уровень "отличник" )

0,0(0 оценок)
Ответ:
elsem78
elsem78
26.01.2021 15:13

var N, i, a, m:integer;

c:boolean;

begin

 writeln('Введите количество участников');

 readln(N);

 if ((N < 1) or (N >50))then begin

   writeln('Ошибка');

   exit;

 end;

 m := 0;

 c := false;

 for i:=1 to N do begin

   writeln('На сколько вопросов правильно ответил ',i,' участник:');

   readln(a);

   if ((a < 0) or (a > 20)) then begin

     writeln('Ошибка');

     exit;

   end;

   

   if (a = 0) then

     c := true;

   

   if (a > m) then

     m:= a;

 end;

 writeln('Количество вопросов, на которые ответил победитель правильно: ', m);

 if (c = false) then

   writeln('Есть ли участники, которые не ответили ни на один вопрос правильно: NO')

 else write('Есть ли участники, которые не ответили ни на один вопрос правильно: YES');

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота