В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
gasisivlasova
gasisivlasova
27.01.2020 12:32 •  Информатика

1.Задан массив символов. Найти сумму порядковых номеров символов массива.
2.Найти сумму и разность тех или элементов одномерного массива.
3.В двумерном массиве чисел найти:
А) след матрицы
Б) сумму элементов по строкам
4.В заданном тексте найти количество заданных строчных и прописных букв.
5. Вычисление суммы и произведение элементов одномерного массива оформить в процедуру и применить для заданных массивов.
6. В заданном тексте, состоящем из 5 строк, подсчитать количество цифр, букв, знаков препинаний написать на С++ голова совсем не шарит

Показать ответ
Ответ:
antonnetyaga
antonnetyaga
10.07.2022 06:40
F = ¬X +Z⇒(X+¬Y)
таблица истинности:
X Y Z     X+¬Y   Z⇒(X+¬Y)    ¬X      F
0  0  0      1             1                1       1
0  0  1       1            1                1       1
0  1  0       0            1                1       1
0  1  1       0            0                1       1
1  0  0      1             1                0       1
1  0  1       1            1                0       1
1 1   0       1            1                0       1
1  1  1      1             1                0       1
F =1 тождественно истинна ,
 так как её значения равны 1 при любых X,Y,Z
0,0(0 оценок)
Ответ:
Polly2011
Polly2011
22.11.2021 17:55
Const n=10; 
type ar=array[1..n+1] of integer;
var 
a:ar; i,p:integer; 
procedure pr(var a:ar; p:integer; var k:integer);
begin
k:=1;
while a[k]<>p do k:=k+1;
end;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(31);
 write(a[i]:4);
 end;
writeln;
p:=17;
a[n+1]:=p;
pr(a,p,i);
if i<n 
 then writeln('Значение 17 найдено, номер элемента = ',i)
 else writeln('Значения 17 в массиве нет');
end.

Пример:
Массив A:
  14   5   7  17  25  15  28   0  24   0
Значение 17 найдено, номер элемента = 4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота