1 задание: Для приведенной ниже числовой
последовательности написать программу для вычисления числа:
2 задание: Постановка задачи. Написать оптимальную (по числу
арифметических операций) программу для вычисления приведенной ниже
функции. Построить график данной функции на отрезке [a; b], а также график
касательной к ней в точке с абсциссой хо.
3 задание: Постановка задачи. Затабулировать функцию двух переменных z(x,y)
внутри квадрата xmax ≥ x ≥ xmin и ymax ≥ у ≥ ymin и области существования
функции z. Шаги табуляции Δх = Δу. Результаты вывести на рабочий лист
Excel. В точках, где функция не определена вывести 4 символа «*». Выделить
различным цветом точки, в которых функция определена и точки, в которых
функция не определена.
ВАРИАНТ 5( скрины заданий по порядку от 1 до 3
using namespace std;
int main(){
int a,s,d,f;
setlocale(0,"");
cout<<endl<<"Введите возраст Коли:";
cin>>a;
cout<<endl<<"Введите возраст Миши:";
cin>>s;
if (a>s && a>0 && s>0) {
d=a-s; f=(a+s)/2;
cout<<endl<<"Коля старше Миши на: "<<d<<" лет"<<endl;
cout<<"Средний возраст ребят: "<<f<<" лет"<<endl;
}
if (a<s && a>0 && s>0) {
d=s-a; f=(a+s)/2;
cout<<endl<<"Миша старше Коли на: "<<d<<" лет"<<endl;
cout<<endl<<"Средний возраст ребят: "<<f<<" лет"<<endl;
}
if (a<0 || s<0) {
cout<<endl<<"Вы ввели отрицательное число"<<endl;
}
system ("pause");
return 0;}
алг
нач
опустить перо
сместиться на вектор (0,4)
сместиться на вектор (-1,-1)
поднять перо
сместиться на вектор (4,-3)
опустить перо
сместиться на вектор (-2,0)
сместиться на вектор (2,2)
сместиться на вектор (0,2)
сместиться на вектор (-2,0)
поднять перо
сместиться на вектор (3,0)
опустить перо
сместиться на вектор (2,0)
сместиться на вектор (-2,-2)
сместиться на вектор (2,0)
сместиться на вектор (-2,-2)
поднять перо
сместиться на вектор (5,0)
опустить перо
сместиться на вектор (0,4)
сместиться на вектор (-2,-3)
сместиться на вектор (2,0)
поднять перо
сместиться на вектор (1,-1)
опустить перо
сместиться на вектор (2,0)
сместиться на вектор (0,2)
сместиться на вектор (-2,0)
сместиться на вектор (0,2)
сместиться на вектор (2,0)
поднять перо
сместиться на вектор (3,0)
опустить перо
сместиться на вектор (-2,-2)
сместиться на вектор (0,-2)
сместиться на вектор (2,0)
сместиться на вектор (0,2)
сместиться на вектор (-2,0)
поднять перо
сместиться на вектор (3,-2)
опустить перо
сместиться на вектор (2,4)
сместиться на вектор (-2,0)
сместиться на вектор (3,0)
опустить перо
сместиться на вектор (0,-4)
сместиться на вектор (2,0)
сместиться на вектор (0,2)
сместиться на вектор (-2,0)
сместиться на вектор (2,0)
сместиться на вектор (0,2)
сместиться на вектор (-2,0)
поднять перо
сместиться на вектор (3,-4)
опустить перо
сместиться на вектор (2,2)
сместиться на вектор (0,2)
сместиться на вектор (-2,0)
сместиться на вектор (0,-2)
кон