В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
FalconGamer
FalconGamer
25.07.2021 21:19 •  Информатика

10 класс составьте программу, позволяющую ввести фамилию, имя и отчество учащегося, разделенные пробелом, и вывести фамилию и инициалы. пример ввода: иванов сергей михайлович { строка s } пример вывода: иванов с. м. паскаль

Показать ответ
Ответ:
den4ik143
den4ik143
04.08.2020 20:33

var

str: string;

i,k: integer;

begin

write('Введите фамилию, имя и отчество: ');

readln(str);

for i:=1 to length(str) do

begin

if (str[i]<>' ')and(k=0) then

write(str[i]) else

if str[i]=' ' then

begin

inc(k);

write(' ',str[i+1],'.');

end;

end;

readln;

end.


попробуй эту программу.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота