В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
evasuperpuper123
evasuperpuper123
24.02.2020 11:26 •  Информатика

100 ! составьте программу на языке паскаль: вычислите длину(l) отрезка ав, а(ха, уа) и в(хв, ув), l=корень из (ха+уа)^2+(хв+ув)^2

Показать ответ
Ответ:
haikyuu24
haikyuu24
08.10.2020 14:55
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (xa,ya):=ReadReal2('Введите координаты х и у точки А:');
  var (xb,yb):=ReadReal2('Введите координаты х и у точки B:');
  Writeln('Длина отрезка АВ равна ',Sqrt(Sqr(xb-xa)+Sqr(yb-ya)))
end.

Пример
Введите координаты х и у точки А: 3.7 -2.96
Введите координаты х и у точки B: 11 8.4
Длина отрезка АВ равна 13.503318110746
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота