В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Danielufa
Danielufa
26.10.2020 04:22 •  Информатика

15 ! нужно составить программу в паскаль. если сумма различных целых чисел х, у, z меньше 30, то заменить меньшее из у и х суммой двух других. в противном случае увеличить все числа на 10

Показать ответ
Ответ:
Var x,y,z:integer;
begin
write('x='); readln(x);
write('y='); readln(y);
write('z='); readln(z);
if x+y+x<30
  then  if x<y then x:=x+y else y:=x+y
  else begin x:=x+10; y:=y+10; z:=z+10 end;
writeln('x=',x,'  y=',y,'  z=',z);
end.

Пример:
x=7
y=12
z=9
x=19  y=12  z=9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота