Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
шапан1
16.12.2021 18:01 •
Информатика
16. составьте программу для вычисления числа n: n = 1∙2∙3∙…∙х. число х вводится с клавиатуры.
Показать ответ
Ответ:
bill3334
06.10.2020 12:37
function factorial(n : integer) : BigInteger;
var
i : integer;
f : BigInteger;
begin
f := 1;
for i := 2 to n do
f := f * i;
factorial := f
end;
var
x:integer;
begin
write('X: ');
readln(x);
writeln(factorial(x));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Artem030405
18.09.2020 16:49
Валя, света и маша изучают различные иностранные языки: , испанский и , каждая знает только один язык. на вопрос, какой язык изучает каждая из них, одна девушка ответила:...
timkazhimov
05.06.2021 23:18
Яке занчення S буде виведено в текстове поле? (вказати число...
DanilVOLK228
27.10.2021 09:28
В одной из кодировок Unicode каждый символ кодируется 16 битами. Петя написал текст (в нём нет лишних пробелов): «Ель, кедр, сосна, кипарис, лиственница, можжевельник...
Trion24
02.03.2022 13:13
Сколько импульсов подсчитает счетчик на 2 триггера?...
НикСол
24.02.2020 19:02
Установите правильный порядок следования блоков программы: Укажите порядок 1 Программный блок 3 Заголовок программы 2 Блок описания используемых данных...
Лера089
04.11.2022 03:31
Подскажите как это делать((...
Алёна0Чан
19.02.2022 11:50
Дан алгоритм для Робота: алг нач нц 51 раз влево; закрасить кц кон Что будет результатом работы этого алгоритма?...
санёк55665464654
22.11.2021 23:07
Напишите программу,в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор,пока не будет введён ноль) и подсчет суммы и среднего арифмитического...
poladasadov
07.06.2021 20:56
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчёт суммы и среднего арифметического...
Nastya90Lapka
23.09.2022 03:30
Гиперсілтеме типтерін сәйкестендір...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var
i : integer;
f : BigInteger;
begin
f := 1;
for i := 2 to n do
f := f * i;
factorial := f
end;
var
x:integer;
begin
write('X: ');
readln(x);
writeln(factorial(x));
end.