В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Vip6longin
Vip6longin
15.06.2021 05:14 •  Информатика

18. написать программу на паскале,дана точка на плоскости с координатами х, у составить программу которая выведет одно из сообщение да нет на границе

Показать ответ
Ответ:
gukalovaekateri
gukalovaekateri
01.10.2020 11:10
int R = 15;
 Console.Write("x=");
float x = float.Parse(Console.ReadLine());
Console.Write("y=");
float y = float.Parse(Console.ReadLine());
if (Math.Sqrt(Math.Pow(x,2) + Math.Pow(y,2)) < Math.Pow(R,2))     Console.WriteLine("внутри");
else if (Math.Sqrt(Math.Pow(x,2) + Math.Pow(y,2)) > Math.Pow(R,2))      Console.WriteLine("вне");
else Console.WriteLine("на границе");
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота