В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

1cоставить программу,которая позволяет ввести строку s,затем после каждой буквы "а" вставить пробел. 2 составить программу,которая удаляет в строке s все буквы "о"

Показать ответ
Ответ:
Lalker1337
Lalker1337
26.06.2020 11:09
На всякий случай сделал проверку и на русские, и на английские.
задача 1.
uses crt;
var i:integer;
s:string;
begin
i:=1;
read(s);
repeat
if (s[i]='a') or (s[i]='а') then
s:=copy(s,1,i)+' '+copy(s,i+1,length(s));
i:=i+1;
until i=length(s)+1;
writeln(s);
end.
задача 2.
uses crt;
var i:integer;
s:string;
begin
i:=1;
read(s);
repeat
if (s[i]='о') or (s[i]='o') then
s:=copy(s,1,i-1)+' '+copy(s,i+1,length(s));
i:=i+1;
until i=length(s)+1;
writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота