В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
alinakim3
alinakim3
03.01.2022 06:47 •  Информатика

1написать программу, которая находит в массиве значения, повторяющиеся два и более раз, и показывает их на экран. 2 написать программу, которая находит в массиве самое маленькое нечетное число и показывает его на экран. для всех : размер массива вводит пользователь. элементы массива рандомно в диапазоне [ 13; 27 ].

Показать ответ
Ответ:
WhiteFix
WhiteFix
06.10.2020 13:43
Int main()

  int  
    numOfEl,          // number of elements in the array
    minNum = 28,  // minimal number in the array   
    *mainArray,      // main array   
    cntArray[15];    // array for counting the repeated numbers

    std::cout << "Input the number of the elements: "; 
    std::cin >> numOfEl;

    mainArray = new int[numOfEl];

    for (int i = 0; i < 15; i++)
      cntArray[i] = 0;   

    for (int i = 0; i < numOfEl; i++)
    {
      cntArray[(mainArray[i] = rand() % 15 + 13) - 13]++;

      if (mainArray[i] < minNum && mainArray[i] % 2 != 0)
        minNum = mainArray[i]; 
    }

#ifdef _DEBUG
    std::cout << "Array: ";
   
    for (int i = 0; i < numOfEl; i++)
      std::cout << mainArray[i] << ";" << std::endl;
#endif

    std::cout << "Repeated numbers: ";
    for (int i = 0; i < numOfEl; i++) 
      if (cntArray[i] >= 2)
        std::cout << i + 13 << "; ";

    std::cout << std::endl << "Minimal number: " << minNum << std::endl;

    system("pause");
   
   return 0;
} /* End of the 'main' function */
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота