В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

№1составить программу проверяющую является ли слово "перевертышем" №2подсчитать каких букв в предложении больше "а" или "е" все в паскале

Показать ответ
Ответ:
lera88273
lera88273
11.06.2020 15:45

var
  S:string;
  i:integer;
begin
  write('S = ');
  readln(S);
  for i := 1 to Length(S) do
    if S[i] <> S[Length(S) - i + 1] then
    begin
      writeln('No');
      readln;
      Exit;
    end;
  writeln('Yes');
  readln;
end.

 

//вторая программа

 

var
  S:string;
  i, countA, countE:integer;
begin
  CountA := 0;
  CountE := 0;
  write('S = ');
  readln(S);
  for i := 1 to Length(S) do
    if S[i] = 'a' then
      inc(countA)
    else
      if S[i] = 'e' then
        inc(countE);
  if countA > countE then
    writeln('a > e')
  else
    if countA < countE then
      writeln('a < e')
    else
      writeln('a = e');
  readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота