В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
evaeva2006
evaeva2006
06.09.2022 10:46 •  Информатика

1вариант #1 написать программу для : вводится двухзначное число,выяснить из четных цифр оно состоит или нет решите ,дана таблица по ней все указанно,2 варианта прорешайте умоляю вас, 40

Показать ответ
Ответ:
Stasikone
Stasikone
10.06.2020 01:24

Так вроде, подставь цифры и всё.

Объяснение:

var

a:integer;

begin

write('введите двузначное число: ');readln(a);

writekn('ответ: ',(a div 10)+(a mod 10));

end.

0,0(0 оценок)
Ответ:
ник5041
ник5041
10.06.2020 01:24

Смотри. Я напишу тебе основную суть на Python . Если не сможешь перевести в паскаль сам, то программирование это не твое.

Объяснение:

1)

a = 62

a_1 = a / 10 # Получаем первую цифру числа. (6)

a_2 = a % 10 # Получаем вторую цифру.

if (a_2 % 2 == 0) and (a_1 % 2 == 0):

   print("Число состоит из четных цифр")

else:

print("Число состоит из нечетных цифр") #Текст заменить на нужный

2) Тут сложнее. Надо бы попробовать в реале, но мне лень.

a = 2

b = 9

for x in range(a, b) : # Это цикл от a до b на пайтоне. Суть ты понял.

    print(x)

3)

for x in range(10, 99)

   a = x

   a_1 = a / 10 # Получаем первую цифру числа.

   a_2 = a % 10 # Получаем вторую цифру.

   if (a_1 + a_2) == (a_1 * a_2):

            print(x)

Второй вариант

1)

a = 62

a_1 = a / 10 # Получаем первую цифру числа.

a_2 = a % 10 # Получаем вторую цифру.

if (a_1 + a_2) > 10:

   print("Больше")

else:

  print("Меньше")

2 задание пропущу. Ибо оч долго для меня.

3)

for x in range(10, 99)

   a = x

   a_1 = a / 10 # Получаем первую цифру числа.

   a_2 = a % 10 # Получаем вторую цифру.

   if (a_1 + a_2)  % 2 = 0 :

            print(x)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота