В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
malvinka011
malvinka011
29.09.2022 05:50 •  Информатика

2. Составить программу тремя Среди чисел 1, 4, 9, 16, 25, … найти первое число, большее n (n – вводится с клавиатуры).

Показать ответ
Ответ:
vipvip16tk
vipvip16tk
13.12.2021 10:01
Const n=20;
var 
a,b:array[1..n] of integer;
i,j,k,m,c:integer; 
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
  a[i]:=random(51)-25;
  write(a[i]:5);
 end;
writeln;
j:=0;
for i:=1 to n do
 if a[i]<0 then begin j:=j+1; b[j]:=a[i]; end;
m:=j;
for k := 1 to m-1 do
  for i := 1 to m-k do
     if (b[i]<b[i+1]) then 
       begin
       c:=b[i]; b[i]:=b[i+1]; b[i+1]:=c;
       end;
writeln('Вс массив:');
for i:=1 to m do write(b[i]:5);
writeln;
j:=0;
for i:=1 to n do
 if a[i]<0 then begin j:=j+1; a[i]:=b[j]; end;
writeln('Полученный массив:');
for i:=1 to n do write(a[i]:5);
writeln;
end.

Пример:
Исходный массив:
  -15   -8   -6  -13   15   24    5   -2   14   -1   19   -2   -7   -8  -23   20   -2    7   -2  -10
Вс массив:
   -1   -2   -2   -2   -2   -6   -7   -8   -8  -10  -13  -15  -23
Полученный массив:
   -1   -2   -2   -2   15   24    5   -2   14   -6   19   -7   -8   -8  -10   20  -13    7  -15  -23
0,0(0 оценок)
Ответ:
fatyaa22
fatyaa22
27.02.2020 03:45

Символ – минимальная единица текстовой информации: цифра, буква, знак препинания и т.д.

Слово – произвольная последовательность символов (букв, цифр и др.), ограниченная с двух сторон служебными символами (пробел, запятая, скобки и др.)

Строка – произвольная последовательность символов между левой и правой границами документа.

Абзац – произвольная последовательность символов, завершающаяся специальным символом конца абзаца. Допускаются пустые абзацы.

Фрагмент — это некоторое количество рядом стоящих символов, которые можно рассматривать как единое целое. Фрагментом может быть отдельное слово, строка, абзац, страница и даже весь вводимый текст.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота