В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Nastyмняша
Nastyмняша
03.12.2022 01:37 •  Информатика

2. составьте программу, определяющую, на какую букву начинается третье слово в предложении. 3*. составьте программу, определяющую длину последнего слова в предложении. желателно в qbasic

Показать ответ
Ответ:
123451529
123451529
27.05.2020 15:49

2.

Program Pr1;
uses crt;
var stroka:string;
i,a,b:integer;
Begin
clrscr;
readln(stroka);
b:=1;
if stroka[b]<>' ' then a:=1
else while stroka[b]=' ' do b:=b+1;
for i:=1 to length(stroka) do begin
if (stroka[i]=' ') and (stroka[i+1]<>' ') then a:=a+1;
if a=3 then begin
writeln(stroka[i+1]);
break;
end;
end;
end.

 

Ойтебе в QBasic...извиняй

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота