В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
swecut
swecut
04.11.2020 11:40 •  Информатика

2.Составьте программу, запрашивающую оценки за две контрольные
работы. Если их сумма не менее 8, то на экран вывести текст
«Молодец!», в противном случае – «Подтянись!»
Язык программирования PascalABC

Показать ответ
Ответ:
lGeneralll
lGeneralll
07.02.2022 15:55

Ну начнем с того, что твоя функция ничего не возвращает, она выводит на экран информацию. Второй косяк в том, что функция isdigit() проверяет всю строку, то есть, при строке с одними цифрами твоя программа даст верный ответ.

Исправить максимально просто, нам нужно проверить каждый символ строки, если встречаем хоть 1 цифру, то возвращаем true, а если не встретим в строке цифр - false.

Максимально простой вариант для новичка, скорее всего, такой:

def number(x):

  for i in x:

      if i.isdigit():

          return True

  return False

print(number('xx'))

0,0(0 оценок)
Ответ:
bulatnurtdinov
bulatnurtdinov
28.03.2023 10:28

N=int(input())

a=[]

sum = 0

f = 0

c = 0

for i in range(N):

 l = int(input())

 sum = sum + l

 a.append(l)

if N == 1:

 print(1)

else:

 ans = []

 for i in range(N-1, 0, -1):

   if a[i] > a[i-1]:

     if sum > a[-1] or (sum > a[i+1] and f == 1):

       for k in range(c+1):

         ans.append(1)

       c = 0

       f = 1

     else:

       ans.append(0)

       f = 0

   elif a[i] == a[i-1]:

     c += 1

   else:

     ans.append(0)

     f = 0

   sum=sum-a[i]

 ans = ans[::-1]

 print(0)

 for i in range(c):

   print(0)

 for i in ans:

   print(i)

Объяснение:

с тебя 500 рублей у меня сегодня др

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота