В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

2. Задан массив E(5, 5) и число а. Найти количество элементов, равных по значению а. Элементы массива из ячеек таблицы Excel. Значение a - ввод на клавиатуре (MsgBox). Вывод также в MsgBox

Показать ответ
Ответ:
miras20081
miras20081
23.09.2021 15:48

Объяснение:

#include <iostream>

using namespace std;

const int max_size = 2000;

class Queue //класс Очередь

{

int q[max_size]; //массив чисел

int left = 0, right = 0; //первый(крайний левый) и последний(крайний правый) элементы массива

public:

void add(int a); //функция для добаления элемента в очередь

void getMinNum(); //функция для получения минимального числа в очереди

};

void Queue::add(int a)

{

if (a != 0)

{ //если введено число больше 0

q[right] = a;

right++;

}

else if (left == right)

{ //если первый и последний элементы совпадают, очередь пуста

cout << -1 << "\n";

}

else

{ //если введен '0'

this->getMinNum();

left++;

}

}

void Queue::getMinNum()

{

int minID = left;

for (int i = left; i < right; i++)

if (q[minID] > q[i])

minID = i;

cout << q[minID] << "\n";

}

int main()

{

int n; //количество операций

Queue q; //объект класса Очередь

int num;

cin >> n;

for (int i = 0; i < n; i++)

{

cin >> num; //вводим число

q.add(num);

}

return 0;

}

0,0(0 оценок)
Ответ:
voegrogo5523
voegrogo5523
04.09.2020 21:09

Чтобы вывести список всех файлов и отсортировать их по размеру, используйте опцию -S. По умолчанию выводится в порядке убывания (от самого большого до самого маленького размера).2Вывести и отсортировать список файлов по размеру

Имеется папка с текстовыми файлами 1) Мы получаем список этих файлов 2) Сортируем их по размеру...

Вывести на экран список файлов заданного каталога, упорядочив их по размеру

надо написать програмку:Вывести на экран список файлов заданного каталога, упорядочив их по...

Вывести список всех файлов текущуго каталога, отсортировать по алфавиту

Написать программу ,которая выводит на экран список всех файлов текущуго каталога,отсортировать по...

Отсортировать содержимое текущего каталога по размеру файлов и произвести его постраничный вывод

Отсортировать содержимое текущего каталога по размеру файлов и произвести его постраничный вывод. ...

18.

3COM - командный файл; EXE - исполнительный файл; BAT - пакетный файл; SYS - системный файл; TXT - текстовой файл; и др. При работе в MS-DOS часто используются шаблоны имени файлов - символы ? и *. Шаблоны употребляются в командах для обозначения сразу нескольких файлов (там, где это допустимо и имеет смысл) или для сокращения записи имен файлов. Знак * в имени или типе файла заменяет любое количество любых символов, а знак ? - любой одиночный символ. Знак ?, помещенный последним в шаблоне имени или типа файла, воспринимается как любой одиночный символ или отсутствие такового. Примеры шаблонов: Р*.* - все файлы с именами, начинающимися с буквы Р; *.PAS - все файлы c расширением PAS; *.* - все файлы на диске; *. - все файлы, у которых отсутствует расширение; ??n.ЕХЕ - все файлы типа ЕХЕ, у которых имя файла состоит из трех символов и последний символ имени буква n; А??В.* - все файлы, имена которых состоят из четырех символов, начинаются с А и последняя буква имени В; D?.* - все файлы, имена которых начинаются на букву D и содержат один или два символа; ???.* - все файлы, имена которых содержат один, два или три любых символа. Применение каталогов предоставляет возможность структурировать и упорядочить дисковое пространство ПК. Каталог - это группа файлов на одном носителе, объединенных по какому-либо признаку (обычно логически взаимосвязанных). Каталог имеет имя и в свою очередь может быть зарегистрирован в другом каталоге. Это значит, что он включен в последний как целое, и тогда говорят, что он является подчиненным каталогом (подкаталогом). Так образуется иерархическая (древовидная) файловая система. На каждом диске 2

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота