В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Masha1211111111
Masha1211111111
23.06.2021 03:35 •  Информатика

20 ! составить программу на языке с++! реализовать программу «телефонный справочник» с использованием двусвязного списка требования к программе: ● максимальное количество записей в справочнике ограничено. ● каждый запись должна содержать следующую информацию: им 'я (до 10 символов включительно), фамилия (до 20 символов), номер телефона (до 12 цифр). все поля обязательно 'обязательными (не могут быть пустыми). ● ключевое поле - номер телефона (в справочнике может существовать только одна запись с указанным номером). ● структура хранения записей в справочнике - двозвьязний список. ● после запуска программа выводит на экран меню: 1. добавить запись 2. удалить запись 3. найти запись 4. показать все записи 5. сортировать записи 6. сохранить в файле 7. скачать с файла 8. выйти из программы и просит пользователя сделать выбор. ● после выбора пользователя программа при необходимости может запросить дополнительную информацию (например, номер телефона для удаления записи). ● после выполнения операции по запросу пользователя программа сообщает о ее результат (успешное завершение или ошибка), просит пользователя нажать любую клавишу для продолжения. затем снова выводит на экран меню. ● для удаления записи необходимо указать номер телефона. ● для поиска записи необходимо указать фамилию или номер телефона. ● сортировка записей выполняется по фамилии и имени. ● имя 'я файла для хранения данных справочника - phone.dat программа должна контролировать ввода пользователем и сохранять работо при введении сознательно неверных данных (например, слишком длинной строки как имени или неразрешенных символов в номере телефона).

Показать ответ
Ответ:
svashalol
svashalol
26.01.2021 00:39

1) (первые 2 скриншота)

#include <iostream>
using std::cout;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;

int main()
{
    int a[10];

    srand(time(0));

    for(int i = 0; i < 10; i++)
    {
        a[i] = rand() % 101;

        cout << a[i] << ' ';
    }
    cout << endl << endl;

    for(int i = 0; i < 10; i++)
    {
        if(a[i] % 3 == 0 && a[i] > 13)
        {
            cout << a[i] << ' ';
        }
    }
    cout << endl;

   return 0;
}

 

2)

#include <iostream>
using std::cout;
using std::endl;

int main()
{
    double a[10] = { 1.2, 0.0, -5.8, -0.4, 10.5, 14.6, -6.3, -8.8, -4.1, 0.0 };
    int A = 0, B = 3;

    for(int i = 0; i < 10; i++)
    {
        cout << a[i] << ' ';
        if(a[i] < 0.0)
        {
            a[i] += a[A];
        }
        else if(a[i] == 0)
        {
            a[i] -= B;
        }
    }

    cout << "\n\na(index) = " << A << ", b = " << B << "\n\n";

    for(int i = 0; i < 10; i++)
    {
        cout << a[i] << ' ';
    }
    cout << endl;

   return 0;
}


1. дан массив. напечатать все элементы кратных 3 и больших 132. дан массив вещественных чисел. ко вс
0,0(0 оценок)
Ответ:
DashaTaylor11
DashaTaylor11
19.05.2022 23:22
Прога написанная в codeblocks: #include < iostream> using namespace std; int main() {          setlocale(lc_all,"russian");           int a[20];           int b, c, i, q=0;           for(i=1; i< 21; i++)          {                  cout< < "введите "< < i< < " число: ";                   cin> > a[i];           }          cout< < "введите начальный номер элемента массива: ";     cin> > b;     cout< < "введите конечный номер элемента массива: ";     cin> > c;     for(int j=b; j< c+1; j++)          {                q+=a[j];         }          cout< < "cумма элементов массива с номерами с "< < b< < " по "< < c< < " равна: "< < q; } я надеюсь тебе была нужна прога на с++))
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота