В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
steamenigasteam
steamenigasteam
18.06.2022 03:20 •  Информатика

3. дано целое трехзначное число а .составить программу, которая выводит сумму цифр данного числа. например, вводится число 423, а выводится число 9.

Показать ответ
Ответ:
lerakycher2001
lerakycher2001
10.10.2020 20:17

===== PascalABC.NET =====

begin

 var n := Abs(ReadInteger);

 var s := 0;

 while n > 0 do

 begin

   s += n mod 10;

   n := n div 10

 end;

 Write(s)

end.


3. дано целое трехзначное число а .составить программу, которая выводит сумму цифр данного числа. на
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота