В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Nurik271100
Nurik271100
12.08.2021 07:14 •  Информатика

3. написать программу, определяющую, лежит ли точка с указанными координатами а (x, y) на окружности радиуса r с центром в начале координат (может лежать на окружности, внутри окружности, вне окружности) ps: pascal(не турбо) всем буду !

Показать ответ
Ответ:
dina79kzkz
dina79kzkz
25.06.2020 09:13
Var
x,y, r: Iinteger;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln®;
If (sqr(x)+sqr(y))=r then writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота