В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
apuha2003p07yqc
apuha2003p07yqc
16.12.2021 16:38 •  Информатика

3.Напишите программу, которая вычисляет сумму четных натуральных чисел в диапазоне
от 1 до 20. Подпишите комментарии на каждой строке рядом с каждым оператором - что
делает этот оператор.​

Показать ответ
Ответ:
starikoe
starikoe
15.10.2020 05:46

#include <iostream>

using namespace std;

signed main() {

   int sum = 0;// переменная-счетчик суммы

   for(int i = 1; i <= 20; i++) // перебор всех вариантов в диапазоне от 1 до 20

       if(i % 2 == 0) // если число четное, то увеличиваем сумму на это число

           sum += i;

   cout << sum; // выводим сумму    

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота