3. Напишите программу «Синоптик», которая по введенной температуре, дает комментарий о погоде и рекомендацию о прогулке. Проявите фантазию. Используйте не менее 5 диапазонов температур. Пример. Входные данные 12 (в ºС). Выходные данные: «Прохладный денек. Одевайся потеплее».
#include <bits/stdc++.h>
using namespace std;
int search1(string str) {
for (int i = 0; i < str.size(); i++) {
if (str[i] == 'f') return i;
}
return -1;
}
int search2(string str) {
for (int i = str.size() - 1; i >= 0; i--) {
if (str[i] == 'f') return i;
}
return -1;
}
int main() {
string str = {};
getline(cin, str);
int a = search1(str);
int b = search2(str);
if (a != -1) {
if (a == b)
cout << a;
else
cout << a << " " << b;
}
return 0;
}
//1)
var x, y: integer;
begin
write('Введите x y: ');
read(x, y);
if x > y then
writeln(x - y)
else
writeln(y - x);
end.
//2)
var a, b, c: integer;
begin
write('Введите a b c: ');
read(a, b, c);
if (a > (b + c)) then
writeln(a)
else
writeln(b + c);
end.
//3)
var x, k: integer;
begin
write('Введите x k: ');
read(x, k);
if k = 1 then
writeln(sin(x))
else
if k = 2 then
writeln(cos(x))
else
writeln('k должен быть равен 1 или 2.');
end.
//4)
var p, m: integer;
begin
write('Введите p, m: ');
read(p, m);
if p > m * 2 then
writeln(p)
else
writeln(m * 2);
end.