В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

3. задан числовой массив а[1: m, 1: n]. составить программу поиска количества отрицательных и положительных элементов массива расположенных над главной диагональю и обнуления тех, количество которых минимально. c или c++

Показать ответ
Ответ:
SonyaNik228
SonyaNik228
26.01.2022 22:53

1)program primer1;

var х,у,z:integer;

{ описание переменных }

begin { начало программы }

х := 3; { установка значения х }

у := 5; { установка значения у }

z := х + у; { вычисление суммы }

write(z); {вывод результата вычисления на экран }

end. { конец программы }

2) program vetvlenija;

uses crt;

var A:real;

begin

clrscr;

write ('Введите число A: ');

readln (A);

if A>=0 then

writeln ('Вы ввели положительное число');

readln

end.

3) program cikle;

var

i, n: integer;

begin

write ('Количество знаков: ');

readln (n);

 for i := 1 to n do

write ('(*) ');

 

readln

end.

Объяснение:

1) линейный, без ничего

2) ветвление - if then

3) цикл - for

0,0(0 оценок)
Ответ:
abduboriy2004
abduboriy2004
11.05.2020 01:48
Const 
n=5;

Var
 ar:array[1..n] of integer;
 ar2:array[1..n] of integer;
 i,k:integer;

 function prost(a:integer):boolean;
 var i:integer;
 b:boolean;
  begin
  b:=true;
   for i:=2 to a div 2 do
    if a mod i=0 then
     begin;
      b:=false;
      break;
     end;
   if a=1 then b:=false;
  prost:=b;
 end;

  begin;
 randomize;
 k:=0;
  for i:=1 to n do
   begin;
    ar[i]:=random(101);
    write(ar[i]:4);
   end;
  writeln;
  for i:=1 to n do
  if prost(ar[i]) then
   begin;
    inc(k);
    ar2[k]:=ar[i];
    write(ar2[k]:4);
   end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота