В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
nika99560
nika99560
10.10.2020 10:35 •  Информатика

30 ! 7 класс написать программу на паскале или на алгоритмическом языке. является ли натуральное число простым. если оно не простое, то найти количество его делителей​

Показать ответ
Ответ:
киви1403
киви1403
08.06.2020 08:24

Відповідь:

Треба перебрати всі числа менші нього по черзі і поділити на них, якщо при діленні получається ціле число то в лічильник, який спочатку рівний нулю додати одиницю, якщо не ціле то перейти до наступного числа. В кінці коли лічильник буде рівний 2 це просте число а ні то це складне і потрібно вивести на екран результат лічильника. Ось приклад на Python:

o=0

m=int(input("Скажи число і я скажу чи воно просте."))

for h in range(1,m+1):

   if(m%h==0):

       o=o+1

if(o==2):

   print("Це число просте")

elif(o==1):

   print("Одиниця є окремим числом(не простим і не складним).")

else:

   print("Це число складене")

print("До побачення, натисни Enter для завершення")

p=input()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота