(30 ). написать программу по информатике. задана следующая : удалить первый элемент кратный трем (в паскале). я плохо понимаю информатику,поэтому по возможности распишите программу целиком.
Первый кратный элемент заменяется на 0 const n = 10; var a : array [1..n] of integer; i,m : integer; begin for i := 1 to n do a[i] := i;
m := 0; i := 1; while (m = 0) and (i<=n) do begin if a[i] mod 3 = 0 then begin a[i] := 0; m := 1; end ; i := i +1; end; for i := 1 to n do writeln (a[i]); end.
const
n = 10;
var
a : array [1..n] of integer;
i,m : integer;
begin
for i := 1 to n do
a[i] := i;
m := 0;
i := 1;
while (m = 0)
and (i<=n) do
begin
if a[i] mod 3 = 0 then
begin
a[i] := 0;
m := 1;
end ;
i := i +1;
end;
for i := 1 to n do
writeln (a[i]);
end.