В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Дурачкао
Дурачкао
24.11.2020 19:57 •  Информатика

(30 ! ): составить программу на языке паскаль для решения следующей : задать одномерный массив случайным образом, элементы которого принадлежат промежутку [-30; 40]; найти количество элементов массива, принадлежащих промежутку [-10; 25).

Показать ответ
Ответ:
MrIgor1337
MrIgor1337
02.10.2020 09:16
Const
    n = 3;
var
  i,s:integer;
  a:array[1..n] of integer;
begin
  s:=0;
  for i:=1 to n do
   begin
     a[i]:=random(71)-30;
     if (a[i]>=-10) and (a[i]<25) then s:=s+1;
   end;
  writeln('Полученный массив:');
  for i:=1 to n do
   write('a[':4,i,']=',a[i]);
  writeln;
 write('Промежутку [-10;25) принадлежат ',s,' элемент(ов)');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота