В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
irashmoylbwg
irashmoylbwg
14.01.2020 08:35 •  Информатика

30 ! составьте программу ,которая формирует массив ,содержащий 12 случайных вещественных чисел ,принадлежащих промежутку от [-10; 30] , и подсчитывает произведение всех отрицательных чисел. вывод в столбец с тремя десятичными знаками.

Показать ответ
Ответ:
katysid155
katysid155
27.06.2020 01:52
var
a:array[1..12] of real;
i:integer;
pr:real;
begin
randomize;

pr:=1;for i:=1 to 12 do begin
  a[i]:=random(41)*0.9-10;
  if (a[i] < 0) then
    pr:=pr*a[i]; 
end;
writeln(pr:5:3)
end.
0,0(0 оценок)
Ответ:
вася772
вася772
27.06.2020 01:52
Uses crt;
var a:array[1..12] of real;
    x:integer;
    p:real;
begin
     randomize;
     p:=1;
     for x:=1 to 12 do
     begin
          a[x]:=random(41)*(random(10)/5)-10;
          writeln('a[',x,']:',a[x]);
          if a[x]<0 then p:=p*a[x];
     end;
     writeln;
     writeln(p:6:3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота