В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
52681
52681
28.08.2021 06:18 •  Информатика

4. дан массив из 12 вещественных элементов. обеспечить заполнение массива с клавиатуры. подсчитать среднее арифметическое элементов массива, больших 1. 1. в программе «: =» обозначает оператор присваивания, знаки «+», «-», «*» и «/» — соответственно опера ствий соответствуют правилам арифметики. определите значение переменной a после выполнения алгоритма: а : = 6 b : = 4 b : = a/2*b a : = 2*а + 3*b в ответе укажите одно целое число — значение переменной a. 2. запишите значение переменной s, полученное в результате работы следующей программы. var s,k: integer; begin s : = 0; for k : = 12 to 15 do s : = s + 13; writeln(s); end. 3. в таблице dat хранятся данные о количестве сделанных учениками (dat[1] сделал первый ученик, dat[2] — второй и т. определите, какое число будет напечатано в результате рабо-ты следующей программы. var k, m, n: integer; dat: of integer; begin dat[1] : = 7; dat[2] : = 9; dat[3] : = 10; dat[4] : = 5; dat[5] : = 6; dat[6] : = 7; dat[7] : = 9; dat[8] : = 8; dat[9] : = 6; dat[10] : = 9; m : = 10; n: = 0; for k : = 1 to 10 do if dat[k] < m then begin m : = dat[k]; n : = k end; writeln(n); end.

Показать ответ
Ответ:
darinabrovender
darinabrovender
10.09.2020 16:21
1 - 48
2 - 52
3 - 4
4 -
var a: array [1..12] of integer;
i,n,k: integer;
srarifm: real;

Begin
For i:=1 to 12 do
begin
read(a[i]);
end;
For i:=1 to 12 do
Begin
if a[i]>1 then begin n:=n+1; K:=k+a[i]; end;
end;
srarifm:=k/n;
writeln;
Write(srarifm);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота