В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
brigr
brigr
27.01.2020 15:02 •  Информатика

4) Даны три целых числа. Определите, сколько среди них совпадающих. Программа должна вывести одно из чисел: 3 (если все совпадают), 2 (если два совпадает) или 0 (если все числа различны). Формат входных данных Вводятся три числа. Формат выходных данных Выведите ответ на задачу. Sample Input: 1 2 3 Sample Output: 0

Показать ответ
Ответ:
Dragon969
Dragon969
15.10.2020 15:51

public class MyClass {

   public static void main(String args[]) {

     System.out.println("1, 2, 3 == " + howManyEqualNumbers(new int[]{1, 2, 3}));

     System.out.println("2, 2, 3 == " + howManyEqualNumbers(new int[]{2, 2, 3}));

     System.out.println("2, 2, 2 == " + howManyEqualNumbers(new int[]{2, 2, 2}));

   }

   

   public static int howManyEqualNumbers(int[] numbers) {

       int result = 0;

       

       for (int i = 0; i < numbers.length; i++) {

           if (i == 0) {

               continue;

           }

           

           if (i == 1 && numbers[i] == numbers[i - 1]) {

               result += 2;

               

               continue;

           }

           

           if (numbers[i] == numbers[i - 1]) {

               result += 1;

               

               continue;

           }

       }

       

       return result;

   }

}

P.S.

Не забывайте нажать " ", поставить оценку, и если ответ удовлетворил, то выберите его как "Лучший" :)


4) Даны три целых числа. Определите, сколько среди них совпадающих. Программа должна вывести одно из
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота