Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
PrinssesBublGum1337
27.02.2022 20:29 •
Информатика
4. массив а размером 10 заполняется по формуле i-4, где i- счётчик индексов. поменять местами второй и предпоследний элементы массива. ( в паскале)
Показать ответ
Ответ:
drobdrod
05.10.2020 06:46
Var
a: array[1..10] of integer;
i: integer;
begin
for i:=1 to 10 do
a[i] := i-4;
a[2] := a[9] + a[2];
a[9] := a[2] - a[9];
a[2] := a[2] - a[9];
for i:=1 to 10 do
write(a[i], ' ');
end.
0,0
(0 оценок)
Ответ:
karolsevilla2017
05.10.2020 06:46
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrGen(10,i->i-4,1); a.Println;
Swap(a[1],a[8]); a.Println
end.
Результаты
-3 -2 -1 0 1 2 3 4 5 6
-3 5 -1 0 1 2 3 4 -2 6
0,0
(0 оценок)
Популярные вопросы: Информатика
LisenokHan
26.03.2020 14:09
Алфавит племени ОРКОВ состоит из 128 символов. Сколько бит занимает каждый символ в этом алфавите?...
Vadimka221105
27.03.2022 12:21
Рисунок размером 1024*2048 кодируется с глубиной цвета 8 бит. Какой его обьем в килобайтах?...
gavrilindan
09.04.2021 11:32
Карточкамен жұмыс Архиватор WinRar WinZip. Қызметін жазу....
06062007ивант
14.07.2022 21:57
1.Для кодирования сообщений используется неравномерный двоичный код: Е - 01, Н - 1, О - 001, Т - 010 2.Закодируйте сообщение: ЕТОН. Для кодирования сообщений используется неравномерный...
Isa22222
24.03.2021 09:24
A[-7; 15; 0; 3; 19; -5; 2; 19; -4; 10]для этого массива написать программу которую найдёт и выводит на экран, минимальная значение его массива...
olaseve2007ls
24.03.2021 09:24
Дано число 2 в степени 1000. найди сумму цифр этого числа. какая из цифр встречается чаще?...
KateKein
11.08.2021 20:39
Всписке s найти количество a)двузначных чисел b)чисел кратных 5...
ivanignatov201
11.08.2021 20:39
Первый элемент списка s равен 1: s[0]=1 . составьте список из 10 элементов, в котором а)каждый следующий элемент больше предыдущего на величину его номера в списке b)каждый следующий...
плщорршелит
11.08.2021 20:39
Человек умеет разрабатывать алгоритмы? компьютер умеет выполнять алгоритмы? только человек является исполнителем? исполнитель разрабатывает алгоритмы?...
Kmamsmajfkf
05.01.2023 03:45
Пример операционной системы с интерфейсом командной строки....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a: array[1..10] of integer;
i: integer;
begin
for i:=1 to 10 do
a[i] := i-4;
a[2] := a[9] + a[2];
a[9] := a[2] - a[9];
a[2] := a[2] - a[9];
for i:=1 to 10 do
write(a[i], ' ');
end.
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrGen(10,i->i-4,1); a.Println;
Swap(a[1],a[8]); a.Println
end.
Результаты
-3 -2 -1 0 1 2 3 4 5 6
-3 5 -1 0 1 2 3 4 -2 6