В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
89153051060
89153051060
07.08.2021 19:08 •  Информатика

4. написать программу, которая вводит массив из n целых чисел и выводит на экран сам массив и сумму всех его элементов. протестировать программу на следующих массивах: а) 1 3 4 -2 б) 0 1 -2 10 11 12 -10 -3 в) 1 1 1 1 -1 -1 -1 -1

Показать ответ
Ответ:
oxxximiro1
oxxximiro1
05.10.2020 12:03
Program n1;
const n=10;
var a: array [1..n] of integer;
i,sum: integer;
begin
sum:=0;
for i:=1 to n do
begin
write('введите ',i,' число: ');
readln(a[i]);
end;
writeln('массив: ');
for i:=1 to n do begin
sum:=sum+a[i];
write(a[i],' ');
end;
writeln;
writeln('сумма: ',sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота