В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Мотылёк62
Мотылёк62
27.03.2023 23:45 •  Информатика

4. написать программу, которая вводит с клавиатуры номер месяца и зависимости от номера месяца, выводит на экран одно из слов: зима, весна, лето или осень.

Показать ответ
Ответ:
Masuki
Masuki
06.10.2020 13:53
// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите номер месяца (1-12):');
  case n of
  3,4,5:Writeln('Весна');
  6,7,8:Writeln('Лето');
  9,10,11:Writeln('Осень');
  12,1,2:Writeln('Зима')
  else Writeln('Неверный номер')
  end
end.

4. написать программу, которая вводит с клавиатуры номер месяца и зависимости от номера месяца, выво
0,0(0 оценок)
Ответ:
wwwrlfoto
wwwrlfoto
06.10.2020 13:53
#include <iostream>
using namespace std;
int main(){
while (1) {    setlocale(0, "rus");    int number;
    cout << "Введите номер месяца " << endl;    cin >> number;    switch (number)    {        case 1: case 2: case 12:            cout << "Зима " << endl;            break;        case 3: case 4: case 5:            cout << "Весна " << endl;            break;        case 6: case 7: case 8:            cout << "Лето " << endl;            break;        case 9: case 10: case 11:            cout << "Осень " << endl;            break;    }
}
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота