4 Напишите программу для создания изображения. Раскрасьте данное изображе- ние по своему усмотрению. Дополнительные команды для построения графических примитивов можно найти в справочной системе.
Информатика - наука об информации и автоматизации информационных процессов. Информация - это новости, новые факты, знания про объекты и явления окружающей среды. Компьютер - устройство или система выполнять заданную чётко определённую изменяемую последовательность операций. Файл - это упорядоченная совокупность данных на внешнем носителе которая имеет имя которое операционная система обрабатывает как единое целое. Текстовой редактор - это самостоятельная компьютерная программа или компонент программного комплекса. Графический редактор - это программа позволяющая создавать, просматривать, обрабатывать и редактировать цифровые изображения на компьютере.
var arr : arr2; n : integer; i, sot, spl, snu : byte; ch : char;
begin write('Хотите использовать заданный по умолчанию массив? (y/n): '); ch := readkey; writeln(ch); sot := 0; spl := 0; snu := 0; if ((ch='y') or (ch='Y')) then begin { Используем заданный по умолчанию } for i:=1 to 12 do begin if arr1[i] > 0 then inc(spl); if arr1[i] < 0 then inc(sot); if arr1[i] = 0 then inc(snu); write(arr1[i], ' '); end; writeln; end else begin { Создаём и заполняем новый массив } write('Введите желаемый размер массива: '); readln(n); setLength(arr, n); writeln('Введите элементы массива:'); for i:=0 to high(arr) do readln(arr[i]); for i:=0 to high(arr) do begin if arr[i]>0 then inc(spl); if arr[i]<0 then inc(sot); if arr[i]=0 then inc(snu); write(arr[i], ' '); end; writeln; end;
Информация - это новости, новые факты, знания про объекты и явления окружающей среды.
Компьютер - устройство или система выполнять заданную чётко определённую изменяемую последовательность операций.
Файл - это упорядоченная совокупность данных на внешнем носителе которая имеет имя которое операционная система обрабатывает как единое целое.
Текстовой редактор - это самостоятельная компьютерная программа или компонент программного комплекса.
Графический редактор - это программа позволяющая создавать, просматривать, обрабатывать и редактировать цифровые изображения на компьютере.
program pr1;
uses
crt;
const
arr1 : array[1..12] of integer = (5, 4, -3, 1, 0, -4, 0, 25, -8, 0, -17, -1);
type
arr2 = array of integer;
var
arr : arr2;
n : integer;
i, sot, spl, snu : byte;
ch : char;
begin
write('Хотите использовать заданный по умолчанию массив? (y/n): ');
ch := readkey;
writeln(ch);
sot := 0;
spl := 0;
snu := 0;
if ((ch='y') or (ch='Y')) then begin
{ Используем заданный по умолчанию }
for i:=1 to 12 do begin
if arr1[i] > 0 then inc(spl);
if arr1[i] < 0 then inc(sot);
if arr1[i] = 0 then inc(snu);
write(arr1[i], ' ');
end;
writeln;
end
else begin
{ Создаём и заполняем новый массив }
write('Введите желаемый размер массива: ');
readln(n);
setLength(arr, n);
writeln('Введите элементы массива:');
for i:=0 to high(arr) do
readln(arr[i]);
for i:=0 to high(arr) do begin
if arr[i]>0 then inc(spl);
if arr[i]<0 then inc(sot);
if arr[i]=0 then inc(snu);
write(arr[i], ' ');
end;
writeln;
end;
writeln('Количество отрицательных элементов: ', sot);
writeln('Количество нулевых элементов: ', snu);
writeln('Количество положительных элементов: ', spl);
end.