4) Напишите программу, которая выводит на экран прямоугольник, состоящий из звездочек (*) (1)
5) В купейном вагоне имеется 9 купе с четырьмя местами для пассажиров в каждом.
Напишите программу, которая определяет номер купе, в котором находится место с
заданным номером (нумерация мест сквозная начинается с 1) (3)
6)
19 % 4
-21 / 4
12 % 4
–7 % (-4)
-7 1/ (-4)
45 1/ 10
(3)
Робототе́хника (от робот и техника; англ. robotics — роботика, роботехник) — прикладная наука, занимающаяся разработкой автоматизированных технических систем и являющаяся важнейшей технической основой развития производства
Робототехника опирается на такие дисциплины, как электроника, механика, кибернетика, телемеханика, мехатроника, информатика, а также радиотехника и электротехника. Выделяют строительную, промышленную, бытовую, медицинскую, авиационную и экстремальную (военную, космическую, подводную) робототехнику.
m, n, i, j: integer;
s: real;
a: array[,] of real;
write('Введите S: ');
read(s);
write('Введите M, N: ');
read(m, n);
setlength(a, m + 1, n + 1);
writeln('Введите элементы матрицы: ');
for i := 1 to m do
for j := 1 to n do
read(a[i, j]);
for i := 1 to m do
begin
for j := 1 to n do
if a[i, j] <> s then
begin
writeln(a[i, j]);
break;
end;
if a[i, j] = s then
writeln('-');
end;
end.
Пример:
Введите S: 7
Введите M, N: 3 4
Введите элементы матрицы:
7 4 3 7
3 5 1 4
7 7 7 7
4
3
-
Объяснение:
нажмите лучших ответ и лайк