В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

47. дано целое четырехзначное положительное число n. составьте программу,которая определяет,какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n. составьте программу, которая определяет, кратно ли пяти произведение его цифр

Показать ответ
Ответ:
Marinap0385
Marinap0385
11.06.2020 14:48

var

  n:integer;

begin

  write('n = ');

  readln(n);

  if (n mod 10) > ((n div 100) mod 10) then

    writeln('Последняя больше второй')

  else

    if (n mod 10) < ((n div 100) mod 10) then

      writeln('Вторая больше последней')

    else

      writeln('Они равны');

  readln;

end.

 

 

 

// Вторая программа

var

  n, Pr:integer;

begin

  write('n = ');

  readln(n);

  Pr := 1;

  while n > 0 do

  begin

    Pr := Pr * (n mod 10);

    n := n div 10;

  end;

  writeln('Pr = ', Pr);

 

  if Pr mod 5 = 0 then

    writeln('Кратно')

  else

    writeln('Некратно');

  readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота