В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
slyusarevqaowko3q
slyusarevqaowko3q
09.07.2021 01:19 •  Информатика

5. дан двумерный массив целых чисел. составить программу, которая определяет, есть ли в некотором столбце массива хотя бы один элемент, кратный заданному числу.

Показать ответ
Ответ:
denchenchik02
denchenchik02
09.10.2020 12:12
PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var (m, n) := ReadInteger2('Количество строк и столбцов в массиве:');

 Writeln('*** Исходный массив ***');

 var a := MatrRandom(m, n, -99, 99);

 a.Println(4);

 Writeln(4 * a.ColCount * '-');

 var nCol := ReadInteger('В каком столбце ищем?');

 var C := ReadInteger('На кратность чему проверить?');

 if a.Col(nCol - 1).Any(t -> t mod C = 0) then

   Writeln('Есть такие элементы')

 else Writeln('Таких элементов нет')

end.


5. дан двумерный массив целых чисел. составить программу, которая определяет, есть ли в некотором ст
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота