В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
юсик17
юсик17
12.10.2021 14:16 •  Информатика

5. Напишите программу, которая заполняет массив из 10 элементов случайными числами на отрезке
[-2; 2] и находит произведение ненулевых элементов ​

Показать ответ
Ответ:
blackcat18
blackcat18
11.10.2020 15:47

C# 8.0:

using System;

using System.Linq;

...

var Arr = RandomIntArr(-2,2,10);

Console.WriteLine(Arr.Where(x=>x!=0).Aggregate((x,y)=>x*y));

...

static int[] RandomIntArr(int Min, int Max, int ArrLen) {

   Random rnd = new Random();

   int[] Out = new int[ArrLen];

   for (int i = 0; i < ArrLen; i++)  Out[i] = rnd.Next(Min, Max+1);

   return Out;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота